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Overview of Process  

Below shows the series of steps used to complete the timetabling process for your school: 

1. Generate Subjects, Teachers and Facilities list from iNEIS™ 

2. Import school file into Edval  

3. Verify teachers & facilities (rooms) 

4. Edit timetable grid 

5. Edit timetable class data 

6. Staff & schedule classes 

7. View & Verify Timetables  

8. Export timetable to MOE 

 

Note for Schools  

1. Edval timetable is constructed by term and session with validity date range. Please refer to section 8 
Export timetable for details. 

2. Edval timetable is constructed based on existing data in iNEIS system. If you find any missing or 
incorrect information, please inform the consultants. Please do NOT add or change the information 
by yourself as you will encounter error during timetable uploading process. 

3. Edval timetables are set by academic career. Therefore primary schools must have two timetables: 

 Primary section 

 Pre-school section 
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1. Generate Subjects, Teachers and Facilities list from iNEIS 

1.1 Generate List of Subjects 

Login to iNEIS to download the subjects list depending on your school type. These are: Pre-school. 
Primary, Secondary or 6th Form. Primary schools should have two subject lists to download: Pre-school 
and Primary. Some Secondary schools should have two subject lists to download: Secondary and 6th 
Form. 

Step 1.  Navigate to Main Menu > Reporting Tools > Query > Query Viewer. 
 
Step 2. Select Query Name from the Search By drop down menu. 

 
 
Step 3. Enter MOE_TT_INT_SUB in the Begins with field. 

 
 
Step 4. Click on the Search button. 

 
Step 5. The specified query will be listed down in the search result. 
 
Step 6. Click on the HTML link. 
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Step 7. You will be directed to MOE_TT_INT_SUB page.  

 
 
Step 8. Select or enter the values into the Institution, Career, Acad Org, Term and Session fields. 

 
 
Step 9. Click on the View Result button.  

 
 
Step 10. A list of the Subject Code, Subject Name and Government Code will be listed down. 

 
 



Page 4 

 

Step 11. Click on the Excel Spreadsheet link. 

 
 
Step 12. Click OK to save the report. Make sure you rename the file name based on your school code. 
Example: MOE_TT_INT_SUB_1011. If it’s a PRE school subject, the naming convention should be like: 
MOE_TT_INT_SUB_PRE_1011 to identify the difference between pre and primary subject. 

 
 
Step 13. View report in Excel. 

 

 

1.2 Generate List of Facilities 

Login to iNEIS to download the facilities list from your school. 

Step 1. Navigate to Main Menu > Reporting Tools > Query > Query Viewer. 
 
Step 2. Select Query Name from the Search By drop down menu. 
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Step 3. Enter MOE_TT_INT_FAC in the Begins with field. 

 
 
Step 4. Click on the Search button. 

 
 
Step 5. The specified query will be listed down in the search result. 
 
Step 6. Click on the HTML link. 
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Step 7. You will be directed to MOE_TT_INT_FAC page.  

 
 
Step 8. Select or enter the values into the Institution, Acad Org, Career, Term and Session fields. 

 
 
Step 9. Click on the View Result button.  

 
Step 10. A list of the Facility Description and Facility ID will be listed down. 
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Step 11. Click on the Excel Spreadsheet link. 

 
 
Step 12. Click OK to save the report. Make sure you rename the file name based on your school code. 

Example: MOE_TT_INT_FAC_1011. 

 
 
Step 13. View report in Excel. 
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1.3 Generate List of Teachers 

Login to iNEIS to download the facilities list from your school. 

Step 1. Navigate to Main Menu > Reporting Tools > Query > Query Viewer. 
 
Step 2. Select Query Name from the Search By drop down menu. 

 
 
Step 3. Enter MOE_TT_INT_TCH in the Begins with field. 

 
 
Step 4. Click on the Search button. 
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Step 5. The specified query will be listed down in the search result. 
 
Step 6. Click on the HTML link. 

 
 
Step 7. You will be directed to MOE_TT_INT_TCH page.  

 
 
Step 8. Select or enter the values into the Institution, Campus, Career, Term and Session fields. 

 
 
Step 9. Click on the View Result button.  
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Step 10. A list of the Teacher Name and Employee ID will be listed down. 

 
 
Step 11. Click on the Excel Spreadsheet link. 

 
 
Step 12. Click OK to save the report. Make sure you rename the file name based on your school code. 

Example: MOE_TT_INT_TCH_1011. 

 
 
Step 13. View report in Excel. 
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2. Import data to Edval from iNEIS 

2.1 Open Edval file 

Open an Edval timetable template file from your desktop, depending on your school type.  

These are: Pre-school, Primary, Secondary or 6th form. 

 

Step 1. Double click the Edval.exe icon to run the software 
Step 2. Select the template file to open. Navigation: Desktop > School Data > Common Material 
Step 3. File > Save as: <School name> <Year>.etz 

Step 4. Then you can begin working on your own school file – not the original file template. 

 

 

2.2 Set Import / Export format 

Ensure import / export format system is set correctly: 

File > Sync with  System > (Configuration)  

Make sure the system is selected as Brunei Ministry of Education. 

You should also ensure the Folder is pre-set to C:/Edval timetables.. 
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2.3 Import data to Edval from iNEIS 

Import data from MOE via: 

Step 1. Menu path: File > Sync with System > Sync now > (Import) 

  

 

Step 2. In the browser window, navigate to Location of the saved file > (your school code + name) to 
select the three import files: SUB, TCH, FAC – Which are Subjects, Teachers and Facilities. 

For primary schools, please import the same teacher and facility files for both pre-school and primary 
timetables. Pre-school and primary school timetables should be imported with the corresponding 
subject file. 
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3. Check teachers, facilities (rooms) and subjects 

Important Notes: Edval timetable is constructed based on existing data in iNEIS system. If you find any 
missing or incorrect information, please inform the consultants. Please do NOT add or change the 
information by yourself as you will encounter error during timetable uploading process. 

 

3.1 Check Rooms 

Menu path: Rooms > Room data 

Check notes column, and check if your rooms match your school rooms, and that the information is 
showing here in Edval now after import, showing import was successful. 

Some rooms are shared between multiple classes – such as a science lab or music room. In this case, 
leave the HomeGroup field blank. 

 

 

 

3.2 Check Faculties  

Faculty: Means department. Teachers can only be registered in one department for administration, but 
can teach subjects across more than one department – these are “teacher sets”.  

Menu path: Teachers > Faculty data 

Step 1. Click any department name you don’t want, and delete the faculty name. 

Step 2. Add any new department, by typing into the blank white cell at the base of the list. 

Step 3. If desired only - set colour for each department by double clicking the colour cell, and 
selecting a colour. We do not recommend you change the existing department names or colours unless 
really needed. Consistency across schools is desirable. 

Once teachers are assigned faculties in the next step, their codes will appear against the faculty name 
here. 
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3.3 Check Teachers 

Menu path: Teachers > Teacher data (Shortcut = F2) 

Step 1. Check your teacher’s names are correct for your school. 

Step 2. If needed, modify short code (Only 4-5 characters). Use characters from the teachers name in 
the short code to help recognition – this is not a numeric type of code. 

 

Step 3. Select ‘all faculties’ from the drop down on the toolbar at top left of screen. This allows the 
Faculty column to be shown. 

Step 4. Specify MaxLoad, and faculty for each teacher (Faculty means ‘Department’).  
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MaxLoad is the teaching load in periods for a full time teacher, as per MOE requirements. 

 

 

3.4 Check Subjects 

Menu path: Classes > Class data (F6) > More > CS Course Data 

Step 1. Check the subjects look correct for your school 

Step 2. Check the Year value is correct for the subject code – so a Yr11 subject has Yr11 etc 

Step 3. Add the year value to the ‘Year’ field if it’s blank  
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4. Edit timetable grid (bell times) 

Menu path: File > Grid structure 

Step 1. Edit grid row names. These usually refer to the periods. Keep them as one or two characters 
only. If needed, click the name of the row, e.g. ‘1’ and rename by typing a new name – e.g. ‘RC’. RC 
commonly refers to registration classes (or roll call). 

More detailed advice on the grid setup is found at:  

https://help.edval.com.au/portal/helpcenter/articles/grid-structure-period-references 

 

 

Step 2. Edit bell times in the grey column on left, to cause changes for the entire row.  

OPTIONAL: (Rare cases only) Modify any exception periods which may have different bell times to the 
normal periods by changing the bell times of these specific periods after the main or normal ones have 
been set for all days.  

So enter times in the format “8:00-9:00”. You may have a period 1 bell time as “8:00-9:00”, but 
Wednesday period 1 might be slightly different, such as “8:30-9:30”. The times on the left only indicate 
the more common times – if there are variations on some days. 

 

 

 

https://help.edval.com.au/portal/helpcenter/articles/grid-structure-period-references
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Step 3. Classify the period ‘type’ for each period. Types are shown as per the following table. For each 
period row, click the grey cell on the left and (Menu path: More > ..) followed by the desired type to 
apply to all in that row. If it only applies to one specific period – click this cell to apply only to this cell. 

 

Period 
type 

Description Colour Example 

 

Online Regular teaching periods in the grid are ‘online’ periods. 
These can have normal academic subjects scheduled there 

White English, Maths 
classes 

Offline Before / after school. Periods not for normal classes. If all 
years are involved in an activity locked to a specific time, 
classify it offline.  

Yellow CCA, 
Registration, 
Assembly 

Recess / 
Lunch 

A break period within the timetable, such as Recess or 
Lunch 

Orange No classes. 
Teacher duties  

Unused An unused period. Zero bell time range. Rarely used If a 
school has five periods on one day, and six on another – 
but wants to align periods – this can be helpful.  

Black Different 
periods/day 
from day-to-day 
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5. Edit timetable class data 

5.1 Class structure 

Classes can be structured as follows: 

 

Pre-school & Primary schools: 

All group classes – 7A, 7B etc 

Students stay in the same group for all classes. 

 

Secondary schools: 

Homegroups (7A,7B etc) + Electives 

Homegroups: Group classes 

Electives: Grouped classes, or linked group classes. Detailed scenarios are elaborated in chapter 4.3. 

 

6th Form schools: 

All block lines. Students are allocated classes in lines, and don’t have a common home group like 8A. 

 

5.2 Create timetable classes 

Menu path: Classes > Class Data 

 

Edit Class code:  

Step 1. Delete the class code for any class in the template file which you don’t want:   

Select class code cell, and then press DEL to delete all the characters of the class code. Then click away. 

Step 2. Add any new class code if you want to add a new class to the timetable. Do this by typing in a 
new class code in the blank row at the base of the Class data table. You may also press INS Insert key on 
the keyboard, to insert a new row anywhere. The class code format should be: 

<Year> <Course code> <Underscore> <Class identifier> 

Note: Based on the above naming format, the corresponding class section in iNEIS will be <Year><Class 
identifier> 

Example: 7Mat_A for a 7A Maths class. The subject code is MAT/3101. Use the three characters at the 
start and use this in the class code as the course code – 7MAT_A if the subject code is MAT/3101. The 
underline characters show how to understand the code. 

In iNEIS, the class section for this Maths class will be generated as 7A. Please note the exported class 
code should NOT exceed 4 characters. 
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Adding a new class code to blank row at base: 

 

 

 

Assign Faculty: 

For each class code, type in the faculty (department) associated with each subject.  

E.g. For a Physics class, you may enter the faculty ‘Science’ against the class for example. 

 

 

Assign subject code: 

For each class code, enter the subject code, or subject free-text into the subject code field. If you had 
entered the subject name, it should be converted to the code. The official name should also appear in 
the Subject free-text field. 

 

 

Assign number of periods: 

For each class code, enter the number of periods for the class in a week, into the #Per field. If the class is 
5 periods per week, enter ‘5’. If the class has any lessons in an off-line period, such as Registration, enter 
in the format #Per = X+Y (Z), where X=Number of periods Online, and Y=Number of periods offline and 
Z= Number of workload 
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Assign Spread: 

For each class code, enter a value in the Spread column to indicate the desired time pattern. Reports can 
then be prepared, to help show any instances where this request was not found in the timetable. 

Common spread values are: 

NoDouble: Default. All single periods – instead of a double, or two lessons of the same subject on the 
same day.  

Double: The class prefers two sequential periods on the same day (and the rest singles) 

Triple: Three sequential periods. 

For more help on this field, click any cell in the column, and then press F1 for context help. 

 

 

Assign Line 

Enter a value in the Line column, to designate the class structure: 

- Group 7E: Means the classes is a 7E class, and can be swapped to a period with any other 7E class. 
Letter grouping is the basic common core class group – such as for Maths and English. 
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- Group 7-1: Means the class is a 7-1 group class. This is a different way of grouping students than 
core letter groups, and is commonly used for elective subjects – where the students don’t follow the 
usual 7A/7B type grouping.  
A common arrangement is that the students in home groups 7A and 7B are locked together for their 
electives, and distributed across the number group classes 7-1, 7-2 and 7-3, according to any criteria 
set by the school.  
More details will be elaborated in 4.3 Elective classes. 
 

- Line 2: Means all classes that share the same line entry are linked together, and occur at the same 
time as each other. A student can only be assigned one class from Line 2. This format is more 
common for sixth form schools. 
 

- Link = “7Mat_A”: Means the class is linked with the 7Mat_A class. Both classes always occur at the 
same time.  

 
It’s recommended to assign the Teacher Pref and RoomPref here. 
Please note that for linked classes, if you are sharing the same room and/or teacher with the other 
class, Teacher Pref and/or Room Pref should be setup as None.  

 
 

For more help on this field, click any cell in the column, and then press F1 for context help. 

 

5.3 Sixth Form School Classes 

Sixth form schools should use block lines in its subject class structure configuration. The line number 
should be the same as its block number. For example, all classes scheduled in block 1 timeslots should 
be configured under line 1. 

 

 

Registration classes should be configured as Line = ‘Line R’, and Periods = ‘RC’. 
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Sixth form class code format should be: 

Subject classes: <Year> <Course code> <Underscore><block/set number> 

Registration classes: <Year> <Course code> <Underscore><Class Name> 

Examples: 

Year Course Block/Set Line Class code in Edval Class section in iNEIS 

Lower sixth Business 
Studies 

Block 2 Line 2 L6BUS_2 L2 

Upper sixth Chemistry Block 1, set 3 Line 1 U6CHE_1.3 U1.3 

Lower sixth Registration None Line R L6YR_BE01 BE01 

 

Note:  

1. For registration classes (subject code has ‘YEAR’), the year prefix (L6/U6) will not be exported. 
2. Class section in iNEIS should NOT exceed 4 characters, including space. 

 

5.4 (Optional) Elective classes 

Elective classes can be categorized into following scenarios: 

- Electives offered to one home group, at the same timeslot 
- Electives offered to one home group, at different timeslots 
- Electives offered to multiple home groups 

 

Scenario 1: Electives offered to one home group, all at same timeslot 

Example: Students in homegroup 9A can choose one elective from options of Art, Economics or 
Geography.  All 3 elective classes are scheduled on Wednesday 10am-1030am. The 3 classes are all open 
for ONLY 9A students. 

Configuration: 

1. Go to Classes > Class Data, create 3 classes for each elective.  
2. Configure one class to be Line = “Group 9A”.  
3. The two other elective classes should have Link = <Class_code_of_9A_class> 
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Scenario 2: Electives offered to one home group, at different timeslots 

Example: Students in homegroup 9A can choose their electives from options of Art, Economics or 
Geography. All 3 elective classes are scheduled on different timeslots. The 3 classes are all open for 
ONLY 9A students. 

Configuration:  

1. Go to Classes > Class Data, create 3 classes for each elective.  
2. Configure all classes to their homegroup 9A. 
3. There should be no entry in Link, for this scenario. 

 

 

Scenario 3: Electives offered to multiple home groups 

Example: Students in homegroup 9A & 9B can choose one elective from options of Art, Economics or 
Geography.  The 3 classes are all open for BOTH 9A & 9B students. Art + Geography classes are offered 
at the same timeslot, where Economics is offered in a separate timeslot, different from Art + Geography 
classes. 

Configuration:  

Since each elective is offered to 2 homegroups, there should be 2 class codes with each assigned to one 
homegroup.  

1. Go to Classes > Class Data, create 3 classes for each elective. 
2. Configure the elective classes offered to homegroup 9A. All classes should be Group = Group 9A.  

Class code format should be: 
<Year> <Course code> <Homegroup (lower case)><Underscore> <Class identifier> 
Example: 9ARTa_G1 
 

3. If multiple electives are conducted at same time, links should be added as well. In the below 
example, Art + Geography are configured to be scheduled at the same timeslot, where 
Economics class is scheduled at another timeslot. 
 



Page 26 

 

 
 

4. Configure the elective classes offered to homegroup 9B. The classes should be Group = ‘Group 
9B’ and linked to its corresponding class which is ‘Group 9A’. 

 

 

Please note that for linked classes, if you are sharing the same room and/or teacher with the other class, 
Teacher Pref and/or Room Pref should be setup as None, except for the base class. 
In the below example, as 9ARTa_G1 is the base class, its teacher pref and Room Pref should NOT be 
None. Its linked class 9ARTb_G1 shares the same room and teacher. Therefore 9ARTb_G1 class should 
be configured as None in both Teacher pref and Room Pref columns. 
 

 

 

5.5 (Optional) Second teacher or room (Team Teaching) 

OPTIONAL: Sometimes a second teacher (or room) is attached to a class, such as for a practical 
component of the subject. In this case we can create a new class code for the extra teacher (or room) 
and link it to the main class. 

Step 1. Create a new class code. If the subject is BIO, and you want to attach another teacher – use a 
code BIO1 where the number stands for the extra teacher.  

Step 2. Name the subject ‘Biology assistant’ – or so it depicts the extra teacher or room. 

Step 3. Link this with main class. Link = ‘11BIO_A’ (class code of the main class) 

Step 4. Ensure you can see RoomPref column. If not, Click More > Show column > Room prefs 

Step 5. Enter RoomPref=NONE if you do not need a second room, or TeacherPref=NONE if you don’t 
need a second teacher. If you don’t put None, a room will be needed for this class. 

This screenshot below shows the class data setup when 2 teachers teaching Biology in the same room. 
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Step 6. (Details will be covered in chapter 5.1) Enter the teacher or room options for the subject (E.g. 
BIO1) using Teacher > Subject teacher, or Rooms > Subject rooms – just like any other subject. The 
variation BIO1 is a set name for those teachers who can assist this subject – it may or may not be those 
in the BIO set. 

Step 7. This attached class will be linked to the first, and like all other classes – will be staffed, scheduled 
to periods and roomed as part of the normal timetable generation. 

 

5.6 (Optional) Offline classes 

Some schools have classes after school, such as for students who need to catch up on learning / 
remedial. There are also CCA (Co-curricular activities). For these – if the period is non-teaching across all 
years (meaning a normal English class should not be on that period), you should mark the period offline. 
See File > Grid structure.  

The CCA classes should also be classified as offline classes, by marking the #Per value to be for offline 
periods. Click the #Per cell and press F1 to see the syntax: 

X+Y (Z),  

where X is the number of normal on-grid timetabled periods, Y is the number of off-grid timetable 
periods, Z is the number of workload. An entry of #Per = 0+2(0) means a class has no regular teaching 
periods, but two offline periods, with no workload counted. 

In the following example, Sat1 is classified as offline, as all students in all years attend CCA – and there 
are no academic classes able to be scheduled on this period. 
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5.7 Registration Classes 

Registration classes refers to the time assigned to take attendance for the students in the morning. It 
normally occurs before the teaching periods start. We will need to create a new class code to specify the 
registration class in Edval.  

Step 1. Create a new class code, using REG to indicate registration class. For example, use the code 
1REG_A to represent the registration class for Class 1A and 3REG_A to represent the 
registration class for Class 3A. 

Step 2. Enter the subject code for the added class code. Subject Code for registration classes starts with 
subject area YEAR. Year 1 registration classes will have the code Year /1. If unsure of the subject 
code, navigate to the Classes > Class Data page and navigate to More > CS Course Data for the 
list of subjects imported into Edval. Identify the YEAR subjects class codes. 

In the CS Course Data page, the Year column will need to be populated. If it’s a year 1 subject, 
specify Yr1. If it’s Lower Six, specify L6.  

 

Step 3. Since registration classes are offline classes (non-teaching periods), specify 0+5(0) for all 
registration classes in the #Per column. Refer to section 5.6 (Optional) Offline Classes to know 
more about the syntax for Offline classes. 

Step 4. Configure the registration classes to their respective homegroups in the Line column. 

Step 5. Specify RC in the Periods column to indicate it as a registration class. 

Step 6. Enter in the class teacher in TeacherPref and the room used in RoomPref columns.  

This screenshot below shows the class data setup for registration classes.  

 

 

5.8 Allocate teachers to subject areas 

Menu path: Teachers > Subject teachers 

Enter teacher codes for each subject, to specify who CAN teach these subjects. The subject codes are 
drawn from your class codes, so first ensure your classes are all set up, and registered to the right 
faculty/department.  

This is NOT assigning staff to classes – it is purely registering the skills of who is QUALIFIED to teach each 
lesson. Note that you can separate groups of teachers ‘by years’, as some teachers are not able to teach 
more senior year classes in a subject. Where possible, ensure the group covers as many years as 
possible. 
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If a teacher is less preferred for a subject – you can code them as a Fallback. Put brackets around their 
teacher short code, or click their code and then click ‘Fallback’ in the pick window. 

 

 

 

 

 

5.9 Enter preferred teachers  

Where desired, enter a preferred teacher against a class in ‘TeacherPref’. If left blank, this field means a 
staffing selection will be made by you from the available options. 

This field is used for: 

A) Plan your staff allocations before you begin timetabling. 

B) Recording the HOD information on who they want to take each class. Merely assigning a class to 
a teacher is not the same as recording who SHOULD have the class – in case of later changes. 

Step 1. Find out offline if there are any preferred teachers for classes 

Step 2. Menu path: Classes > Class data 

Step 3. Check if the TeacherPref field is showing. If not, then click More > Show column > Teacher Pref 

Step 4. Against any class which has preferred staffing (such as nominated by the head of department) 
type the relevant teacher’s code – or click them from the pick window. 

Step 5. If there are three classes for example, and the HOD has indicated three preferred teachers for 
this subject at that level, you would enter all three teachers as preferences for all three classes – using 
comma separation. E.g. TeacherPref = “COOC, FARM, DUNA” for all three classes of that subject. This 
allows the actual allocation of the teacher to be done as best fits the timetable, since there could be 
more difficulty with any one teacher being assigned any one class. 

 

Note that for most junior classes, there is no real need to enter a TeacherPref, as the focus is on senior 
classes. Staff with load left after senior classes have been allocated will naturally pick up junior classes, 
so entering preferred staffing is simply not really necessary there. 
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5.10 Allocate rooms to subject areas 

Menu path: Rooms > Subject rooms 

Specify the preferred rooms for specialist subjects.  This screen is only used where students need to go 
to a different, specialist room. 

Enter room code for each subject, to specify who which room the subject are taught in. The room codes 
are drawn from your school facility list.  
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6. Staff & schedule classes 

6.1 Allocate staff to classes 

The Class data > TeacherPref  field is used to record who is meant to take each class. The Teachers > 
Staff allocations screen is used to actually assign the classes to teachers. It is also helpful for checking 
staff loading. 

Menu path: Teacher > Staff Allocations (F4 Short-cut key) 

Step 1. Drag classes to teachers to assign them the class – or between teachers, or back to the 
unassigned area to temporarily remove the staffing. 

The LdLeft value (Load left) is the number of periods not yet allocated to that teacher. 

The allocated classes for each teacher are shown grouped in columns by the year of these classes.  

  

 

Classes are grouped by year when allocated to teachers. The class code is shown white. To the left is the 
load value for the class, which is in periods. A class that is assigned to a less preferred teacher, shows 
brackets around the class code to signify this.  

The example also shows that Firi has been assigned 8ENG_B, but they are less preferred. This causes 
brackets around the class (8ENG_B) and also the value of ‘5’ in the Score column – as this class is loaded 
at 5 periods. 

 

6.2 Allocate Classes to Timetable 

This step allow user to create school timetable (year by year) via click-and-drag method to allocate 
classes to timetable periods. Menu path: Classes> Year Timetable. Click on the period where you wish to 
drag from “Need Period” and drop it in the TT grid. 
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6.3 Assign facilities to classes 

Step 1. Menu path: Rooms > Auto room. This will allocate rooms to classes, according to what you 
have specified in Subject rooms. 

You can either click-and-drag a class within a room.  

 

Step 2. Menu path: Rooms > Room master. Click-and-drag a class from one room to another. 
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6.4 (Optional) Split classes – (Using Teacher Timetable) 

Where a class is split across two teachers – each taking some periods of the class separately, there are 
different ways to do this. The following is where you want to split just one or two periods to a teacher. 

Step 1. Allocate the class fully to one teacher first. (As per section 5.1 Teachers > Staff allocations). 
Simply drag the class from the unassigned area below, and drop the class on the teacher to assign it to 
them. This means they currently have the class for all periods. 

Step 2. Ensure the class is scheduled to the timetabled periods. (As per section 5.3). This means you 
can see the lessons on the teacher’s timetable. 

Step 3. Go to this teachers timetable (Teachers > Timetable; shortcut F3) – and click any lesson you 
want to split, giving it to another teacher on that period. 

Step 4. Press More > Change teacher (Or Press Ctrl-T). This opens a selection list for another teacher 
to take the lesson you have selected. 

Step 5. Select a teacher from the list. This teacher will be assigned the class on the selected lesson 
period only. A grey 'S‘ spot also appears, to indicate this is a split class. 

 

In the following example, 7MAT1 has been split on period MonA3 from the regular teacher DALJ. This 
lesson has been allocated to ELLV. You can see the class has ‘S’ spots in grey on DALJ’s timetable – but it 
doesn’t appear there on MonA3, as this lesson is now taken by ELLV. 

  

 

 

 

6.5 (Optional) Split Classes – (Using Teacher Master) 

Teacher master allows you to see the lesson allocation for all teachers in a selected faculty. 

Step 1. Select Menu path: Teachers > Teacher master 

Step 2. Select the faculty from the drop down selector on the toolbar – such as ‘Maths’ 
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Step 3. You can now see the lessons for each class, on each period. Identify the lesson you want to 
split from one teacher to another. 

Step 4. Click this lesson, and drag it, dropping it to assign to the new teacher. 

Step 5. Select Menu path: More > Show teacher loads – if you want to see the load value next to the 
teachers name as shown below – such as DALJ has Ld:1 meaning one under loaded. 

Observe in the following screenshot, 7MAT1 is being dragged from ELLV on MonA3, and could be 
assigned to DALJ as they have Ld:1 left available – and are free this period. You can see they already take 
this class, such as shown below on TueA2. 
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7. Check timetables & Export to MOE 

7.1 Check year structure 

Menu path: Class data > More > Year structure 

Step 1. Check your class structure and period allocations are correct. 

Step 2. Sign off each year with More > Sign off ctrl-E 

Checking and signing off means you have seen the sample year structure, and accept it is what you 
want, in terms of how classes can be arranged together. This means the coding of class data information 
– especially structural information – is correct.  

 

Signing off is simply a check to ensure the user has verified each year structure. Changes to class data 
will reset the flag saying this year has been checked – so always ensure you check visually before 
proceeding further, after any significant changes to class data. 

 

 

 

 

7.2 Teacher timetable 

To see a timetable for a teacher, click Menu path: Teachers > Timetables F3 

Tip: A faster way to see these is to press ctrl-F Find, then enter the teacher code or part of their name 
into the search box, and then press enter. 

An example of a Maths teacher’s timetable is shown below: 



Page 36 

 

 

 

7.3 Year timetables 

Menu path: Classes > Year Timetables 

Drag classes into periods if desired. See the timetable for the year level 

In the following example, three classes 7TEC1, 7TEC2 and 7TEC3 are all linked together (From the Link 
entry in Class data), and being dragged to a new period. During dragging, clash spots appear on other 
periods to show the possible impact if the class was dropped there – such as a teacher clash. The 
teacher clashes are shown with dark blue clash spots – and the word ‘T’ to say Teacher clash. The red ‘S’ 
clash spot shows a Student group clash – as the classes being moved are not able to be scheduled at the 
same period as these other classes. You can of course move one class or group of classes, and then drag 
the ones that were on that period back – to swap the classes between periods. It is easier to do this in 
the Master grid screen though – it’s only one swap operation. 

 

 

7.4 Group (Class) timetable 

To see a timetable for the class group (E.g. 7A), click Menu path: Classes > Group timetable 

Select the group from the drop down (E.g. 7A or 9B etc) 

An example of a group timetable is shown below.  
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7.5 Faculty timetable 

To see a timetable for the faculty (department), click Menu path: Teachers > Faculty timetables 

An example of a Maths faculty timetable is shown below: 

 

 

7.6 Master Grid 

Menu path: Grid > Master grid F11 

This master grid screen shows the timetable for the whole school, for all years. Periods are shown at the 
top of the screen, and all classes which have a lesson in that period column are on at that time. You may 
click the year tag on left, to sort the timetable by that year in a structural way, which groups classes ‘by 
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lines’. Click the Periods text top left or press View > Show spread dots to toggle back to showing the 
timetable chronologically. 

A dark blue spot indicates a teacher clash. It is shown on the classes which both have the clashing 
teachers, but also at the top of the column – to assist the user to know where to look for clashes (I.e. 
there is a clash in that column if a dot is shown at the top). 

A room clash is shown as a yellow spot, and a class on a period it is not allowed to be on (according to 
the period value in class data – such as RC or ‘-6’). For more detailed information on all the different 
clash spots, Click Help > What am I looking at? In the Master grid screen.  

 

You can also move classes around in the master grid, into the specific positions you want. Perform this 
step if you want to copy an existing timetable, or take more manual control on the period assignments. 

Step 1. Click the class to move 

Step 2. Click Space-bar to ‘pick-up’ this class 

Step 3. Click a destination period column 

Step 4. Press space bar to swap 
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8. Export file for MOE 

Menu path: File > Sync with System > Sync now (Short-cut key:  Ctrl-K) 

Step 1. Set date range (From / To) and term / Session. Date range and term/session for each academic 
career are specified as below: 

Acad career Acad year Term/session Valid from Valid to 

Pre-school 2015 1510/T2 13/04/2015 03/09/2015 

Primary 
school 

2015 1510/T2 13/04/2015 03/09/2015 

Secondary 
school 

2015 1520/1 13/04/2015 03/09/2015 

Sports 
school 

2015 1520/1 13/04/2015 03/09/2015 

Sixth form 2015 1520/1 13/04/2015 03/09/2015 

**Please change the date according as well as Term/Session**  

Step 2. Press Export! 

Step 3. The exported file is now saved in C://Edval Timetables – with the file name being of the format 
“Edval export TT <Term> <Date> .psv” (date in format YYYYMMDD) such as: 

Edval export TT 1510-1 20141106.psv (This file will be uploaded to Campus solutions) 
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9. Terminology 

Add years: This is where we add all classes of a year to the grid 

Faculty: Means department. Teachers can only be registered in one department for administration, but 
can be registered in more than one department for teaching purposes – these are “teacher sets”. 

Fix: Fixing clashes means moving classes automatically to different periods, to resolve clashes in 
teachers or rooms. There is also a function to fix clashes by allowing staffing changes – if you want this. 

Group: A class group for 7A has an entry in class data Line column as “Group 7A” which just means it is a 
7A group class. 

Line: Class structure entry, such as ‘Group 7A’ or ‘Line 3’ 

Link: This class data entry means the class is linked to the class specified. You can use this to link a 
7A+7B class together, or even add a new class with no group associated – such as two core classes linked 
together to give students three class options for elective subjects in secondary school. 

Long paths: This option enables the fix clashes function to consider far more changes. It is a form of 
optimising, where it allows swapping of classes that also improve quality in other aspects, such as class 
spreads. If you want to have the least disruption to the timetable for any change, you don’t select Long 
paths. If you have not yet published the timetable to end users, then Long paths is an excellent option to 
select. 

Master Grid: This is the screen used for construction of the timetable. 

MaxLoad: The normal full time teaching load in periods, such as ‘21’. 

MixGroup: A group of core classes such as 7A+7B, which band together for the purposes of allowing 
students to attend elective classes outside their regular class groups. A Mix group may be 7A+7B which 
is the same as 7-1 + 7-2 + 7-3 

Optimise: Optimises the allocation of lessons to periods, to better spread them through the day, or 
spread them in the desired pattern of doubles and singles. 

Depth: This refers to the search depth. A depth of one is a shallow search, where depth two means 
search all possibilities of swapping one class with all others, then – again – all possible swaps from that 
state. A depth three fix clashes operation may take a long time, as it effectively means asking Edval to 
search a very large number of possible staff swaps. Generally depth two is adequate for most uses. 

Subject teachers: The set of teachers who are capable of taking a particular subject. 

Subject rooms: The set of rooms for a particular subject. 

 

End of document 


